Excel 2016 for Windows
Pivot Tables

Analyzing Tabular Data

Tim Hill

Questing Vole Press
By the Same Author

Excel 2016 for Mac Pivot Tables


Mastering Excel Loan & Mortgage Formulas

Mastering Excel Sum & Count Formulas

Mastering Excel Date & Time Formulas

Essential Algebra: A Self-Teaching Guide

Essential Trigonometry: A Self-Teaching Guide

For a complete list of titles, go to questingvolepress.com.
Contents

1. Pivot Table Basics
   - Downloading the Sample Workbook
   - Data Requirements for Pivot Tables
   - Creating Pivot Tables
   - Laying Out Pivot Tables
   - Refreshing Pivot Tables
   - Formatting Pivot Tables
   - Showing a Value’s Source Data
   - Changing a Pivot Table’s Source Data

2. Nesting Fields
   - Adding Nested Fields
   - Showing and Hiding Levels

3. Grouping Items
   - Grouping by Selected Items
   - Grouping by Time Periods
   - Grouping by Numbers

4. Calculations and Custom Formulas
   - Calculating Common Statistics
   - Calculating Multiple Statistics
   - Adding Custom Calculations

5. Filtering Data
   - Report Filters
Slicers
Group Filters

6. Charting Pivot Tables
   Creating Pivot Charts
   Customizing Pivot Charts

7. Tricks with Pivot Tables
   Creating a Frequency Tabulation
   Unlinking a Pivot Table from its Source Data
   Converting a Summary Table to a List
   Controlling References to Pivot Table Cells
   Replicating a Pivot Table for Report Filter Items
   Sorting a Pivot Table Manually
1. Pivot Table Basics

You can use Excel’s **pivot tables** to quickly create concise, flexible summaries of long lists of raw values, without having to write new formulas, copy and paste cells, or reorganize rows and columns. Pivot tables are **dynamic**: if you create a pivot table from, say, census data, then you can drag your mouse to rearrange the table so that it summarizes any variables of interest—age, gender, location, education, income, and so on. Rearranging a pivot table by swapping or moving rows and columns is called **pivoting**: turning the same information to view it at different angles. The jargon associated with pivot tables (“n-dimensional cross tabulations”) makes them look complex, but they’re really no more than an easy way to build flexible summary tables.

Excel offers other features for analyzing large amounts of data—including outlines, automatic subtotals, and statistical functions—but if you’re working with hundreds (or hundreds of thousands) of rows, then pivot tables are the best way to look at the same information in different ways, summarize data on the fly, and spot trends and relationships.

**Downloading the Sample Workbook**

To create a pivot table, you need a long list of raw data values to summarize. (A short list works too but doesn’t show the real power of pivot tables.) To follow along with the examples in this book, download the Excel workbook **orders16.xlsx** from [questingvolepress.com](http://questingvolepress.com). In orders16.xlsx, the worksheet named Source Data contains a list of 2155 records (rows) from grocery-item orders.
Data Requirements for Pivot Tables

Pivot tables let you make comparisons and answer specific questions. To work well with pivot tables, a data list needs to meet the following criteria.

At least one column has duplicate values

Pivot tables are used to divide a list into logical levels (categories) and calculate statistics for each level. In the sample orders list, the column Customer, for example, has multiple records with the same value (denoting repeat customers). You can summarize the items ordered by each customer where each distinct customer is one level. In real-life data, the number of distinct values in a categorical column ranges from a few (gender or marital status, for example) to a few hundred (geographic location or part number); beyond a few hundred distinct values, analysis becomes unwieldy unless you **group** or **filter** categories.

At least one column has numerical values

Numerical values are used to **calculate** statistics (sum, count, average, maximum, percentage, rank, custom formula, and more) for each column and level of interest. For non-numerical columns, the only statistics that you can calculate are **frequency tabulations**: counts of the number of levels (distinct values) in the column.
Sample Workbook Columns

The orders list in the sample workbook contains the following columns.

Order ID
Categorical. Identifies an order uniquely. An order for multiple products spans multiple rows. Order 10248, for example, spans rows 2, 3, and 4 (one product per row). Though the order IDs are numbers (10248, 10249,...), this column is actually categorical because it makes no sense to do mathematical operations on its values (summing IDs is meaningless, for example).

Product
Categorical. The brand name of the ordered product (Jack’s New England Clam Chowder, Manjimup Dried Apples, and so on).

Category
Categorical. The type of the ordered product (Seafood, Produce, and so on).

Unit Price
Numerical. The selling price of a single unit of the ordered product.

Quantity
Numerical. The number of units of the product sold in the order.

Customer
Categorical. The name of the buyer.

Ship City
Categorical. The city (in Ship Country) where the order was shipped.

Ship Country
Categorical. The country where the order was shipped.

Order Date
Categorical. The date that the order was placed.

Creating Pivot Tables

To create a new pivot table, you run the Create PivotTable wizard, which lets you select the data to summarize and position the pivot table on a worksheet. You can then structure the pivot table and organize and filter your data however you like.
To create a pivot table:

1. Select the range of cells (including column titles) that you want to use for the pivot table. Alternatively, select a single cell in the range and Excel will expand the range automatically; if Excel misidentifies the range, you can fix it in the next step.

   It’s actually preferable to use a table (Insert tab > Tables group > Table, or press Ctrl+T) instead of selecting a range of cells. That way, Excel automatically accounts for any new rows that you add to the source data when you refresh the pivot table. If you use a range instead of a table, then you must redefine the data source if you add new rows to the end of the range (PivotTable Tools > Analyze tab > Data group > Change Data Source).

2. Choose Insert tab > Tables group > PivotTable.

   Alternatively, if you’re creating a pivot table for a table that you defined with Insert tab > Tables group > Table, you can select any cell in the table and then choose Table Tools > Design tab > Tools group > Summarize with PivotTable.

   The Create PivotTable dialog box opens. Excel automatically chooses “Select a table or range”, with the table name or cell range that you selected. (To create a pivot table based on an external database, you must first configure your database as an external data source: choose Data tab > Connections group.)
3. Select “New Worksheet” to create a new worksheet for the pivot table (typically the best option).

Alternatively, choose “Existing Worksheet” to insert the pivot table on a worksheet that’s already in your workbook. Specify the cell reference for the top-left corner of the pivot table. Excel overwrites any values in the target cells when it creates the pivot table.

In general, it’s safest to place a pivot table on its own new worksheet. If you restructure the pivot table, it can grow to overwrite other values on the sheet (Excel warns you before overwriting existing data).

4. Click OK.

Excel inserts the new pivot table. The pivot table appears as an empty placeholder until you define the rows, columns, and values to use to summarize the source data. When you select a cell inside the pivot table, Excel displays the PivotTable Fields pane on the right, which lists all the columns in the source data.

If you chose to create a new worksheet, Excel gives the sheet a generic name (Sheet1 or whatever) and then places it before the worksheet that contains the source data. You can rename the new worksheet (double-click its worksheet tab) or drag its worksheet tab left or right to reposition it.
Data Models

In the Create PivotTable dialog box, the “Add this data to the Data Model” checkbox lets you build a pivot table that combines data from multiple, related tables. You can build a **data model** within Excel or choose Data tab > Get External Data group to import tables from files, webpages, or database management systems such as Microsoft Access, SQL Server, or Oracle. To add or edit table **relationships** (common fields, such as IDs or standard abbreviations, that link the tables), choose PivotTable Tools > Analyze tab > Calculations group > Relationships. To set data-model options, choose File tab > Options > Advanced (on the left) > Data section. The pivot tables in this book use a single table as the underlying data source, but multi-table data sources work similarly after you set up relationships.

Recommended Pivot Tables

The Recommended PivotTables feature lets you create a new pivot table quickly based on Excel’s analysis of your data. Select the source data and then choose Insert tab > Tables group > Recommended PivotTables. Excel displays previews of recommended pivot tables based on the data. If you don’t like any of Excel’s suggestions, click Blank PivotTable.

Deleting a Pivot Table
A pivot table is a monolithic grid, meaning deletion is all-or-nothing. Excel won’t let you insert or delete individual cells, rows, or columns in a pivot table.

To delete a pivot table:

1. Select the entire pivot table.

To select the entire pivot table, drag to select all the pivot table’s cells (including headers). Or select any cell in the pivot table and then choose PivotTable Tools > Analyze tab > Actions group > Select arrow > Entire PivotTable.

2. Press Delete.

Tip: Deleting a pivot table turns any of its associated pivot charts into standard charts that you can no longer pivot or update.

Laying Out Pivot Tables

To lay out a pivot table, you use the PivotTable Fields pane. Drag columns, called fields, from the “Choose fields to add to report” list into any of the four boxes underneath (use the search box to find fields quickly in long lists). You can also select the checkbox next to a field; Excel will place it in a box depending on the field’s data type (if Excel guesses wrong, drag the field to the correct box). Excel updates the pivot table dynamically as you add, rearrange, or remove fields in the four lower boxes.

The PivotTable Fields pane appears when you select any cell in a pivot table. If it doesn’t appear, choose PivotTable Tools > Analyze tab > Show group > Field List.

Tip: The examples in this book use the default view (“Fields Section and Areas Section Stacked”) of the PivotTable Fields pane. To change the view, click near the top-right corner of the pane. The default view is designed for a small number of fields. The other views are optimized for adding, removing, or rearranging many fields.
A pivot table has four areas:

**Values**
These fields are the numerical values for which you want to display sums, averages, counts, and other statistics. You can drag the Unit Price field here, for example, to calculate price statistics. (If you drag a non-numerical field to Values, only counts are calculated.) For details, see Calculations and Custom Formulas.

**Rows**
These fields group the data into levels, one level per row. You can drag the Category field here, for example, to show product categories (Beverages, Condiments, and so on).

**Columns**
These fields also create levels, one level per column. You can use both Rows and Columns to divide your data in multiple ways in the same pivot table. Drag Ship Country to Rows, Category to Columns, and Quantity to Values, for example. The pivot table divides sales figures into rows by country and columns by product category, answering the question, “Which types of products sell best in each country?”.
Filters

These fields limit the data displayed in the pivot table. To show a breakdown of U.S.-only sales by product category, for example, drag Ship Country to Filters and then configure the filter to show only “USA” values. For details, see Report Filters.

Rearranging (Pivoting) a Pivot Table

In the PivotTable Fields pane, you can remove or move fields at any time to rearrange (pivot) the pivot table.

To remove a field from a pivot table:

- Do any of the following:
  - Drag the field from any box out of the PivotTable Fields pane (the mouse pointer changes to × as you drag).
  - Click the field in a box and then choose Remove Field from the pop-up menu.
  - Clear the checkbox next to the field name in the field list.

To move a field from one area to another:

- Do any of the following:
  - Drag the field from one box to another.
  - Click the field in a box and then choose a “Move to” command from the pop-up menu.

Row or Column Label?

Choosing whether a field appears as a row or column label is a matter of formatting and readability (either way, the same data are displayed). Fields with long category names or many distinct values typically work better as row labels (as column labels, they stretch or proliferate columns). The Product field, for example, works best as a row label; as a column label, the pivot table would be 77 columns wide (Alice Mutton, Aniseed Syrup,..., Zaanse koeken) and hard to read and print.
Moving a Pivot Table

You can move a pivot table to a new worksheet or an existing one. Select any cell in the pivot table and then choose PivotTable Tools > Analyze tab > Actions group > Move PivotTable.

PivotTable Options

You can change the most common pivot-table settings by using the ribbon or the PivotTable Fields pane, but you can find many others in the PivotTable Options dialog box. To open it, right-click any cell in the pivot table and then choose PivotTable Options (or choose PivotTable Tools > Analyze tab > PivotTable group > Options).

Tip: Settings changed in the PivotTable Options dialog box apply to only the active pivot table.

Layout Examples

The following example creates a summary that compares products and shipping locations. The result is a two-dimensional pivot table. Most pivot tables seen in
practice are two-dimensional, meaning that they summarize two different fields.

---

**Tip:** If you’re using the [sample workbook](#) to follow along, the look of your pivot tables depends on which [report layout](#) (compact, outline, or tabular form) you choose.

---

**To compare products and shipping locations:**

1. If necessary, create a new pivot table.

2. In the PivotTable Fields pane, drag the Product field to the Rows box underneath.

   Excel fills in all the product names from the source data from top to bottom (in alphabetical order), one product per row.

3. Drag the Ship Country field to the Columns box.

   Excel fills in all the country names from the source data from left to right (in alphabetical order), one country per column.

4. Drag the Quantity field to the Values box.

   This step chooses which data to examine. Excel fills the pivot table with the numbers of products that were ordered by customers in various countries. The default calculation for pivot tables is the sum of each field in the Values box (note the label “Sum of Quantity” in the Values box). In this example, each value is the total number of units of a specific product shipped to a specific country.

   Pivot tables also calculate subtotals and grand totals. To see them, scroll to rightmost or bottommost end of the pivot table. The grand total is in the bottom-right corner.
You can also nest fields by placing them together in the Rows or Columns box. For example, starting with an empty pivot table, drag Product to the Rows box, drag Ship Country to the same box (placing it below Product), and then drag Quantity to the Values box. The order of fields within a box determines their nesting order in the pivot table (here, Ship Country is nested within Product). For details, see Nesting Fields.

A one-dimensional pivot table has a single field in either the Columns or Rows box (but not both). For example, starting with an empty pivot table, drag Product to the Rows box and then drag Quantity to the Values box. The resulting pivot table simply totals the number of units sold by product.
Refreshing Pivot Tables

Unlike formulas, charts, and most other elements in Excel, pivot tables don’t auto-update when the underlying data change. If you change the source data, the pivot table can show out-of-date calculations. A refresh makes Excel scan the source data and recalculate the pivot table.

To refresh a pivot table manually:

- Do any of the following:
  - Right-click the pivot table and then choose Refresh.
  - Select any cell in the pivot table and then press Alt+F5.
  - Select any cell in the pivot table and then choose PivotTable Tools > Analyze tab > Data group > Refresh (or click Refresh All to refresh all pivot tables in the active workbook).
To autorefresh a pivot table when you open a workbook:

- Select any cell in the pivot table and then choose PivotTable Tools > Analyze tab > PivotTable group > Options > Data tab > select “Refresh data when opening the file”.

**Tip:** A refresh can take a long time depending on the amount of source data, the complexity of the pivot table, the speed of your computer, and other factors. After starting a refresh, you can review its status or cancel it at any time by choosing Refresh Status or Cancel Refresh from the Refresh menu.

**Autoformatting on Refresh**

If a pivot table becomes misformatted when you refresh it, select the “Autofit column widths on update” and “Preserve cell formatting on update” checkboxes on the Layout & Format tab in the PivotTable Options dialog box (PivotTable Tools > Analyze tab > PivotTable group > Options).

**Deferring Updates**

By default, Excel regenerates a pivot table—and any associated pivot charts—every time that you drag a field to or from a box in the PivotTable Fields pane. If pivot-table calculations involve a large data source or many nested fields, then refresh can be intolerably slow.

To disable autorefresh, select the Defer Layout Update checkbox at the bottom of the PivotTable Fields pane. When this setting is turned on, Excel doesn’t refresh the pivot table as you change it. To see the effects of your changes, refresh the pivot table.
manually by clicking the Update button (next to the checkbox), or clear the Defer Layout Update checkbox to go back to automatic refresh.

**Disabling Undo for Large Data Sources**

If a pivot table is linked to a large data source, then undoing refresh operations slows performance because Excel must track and recalculate the pivot table’s prior states. You can turn off undo for time-consuming refreshes without affecting minor refreshes or other types of undo operations. Choose File tab > Options > Advanced (on the left) > Data section. To turn off undo for large data sources, lower the undo threshold for “Disable undo for PivotTables with at least this number of data source rows (in thousands)”. To disable undo for all pivot tables, set this value to zero.

On the other hand, you can enable undo for *all* pivot tables (which is convenient but can significantly slow Excel): clear “Disable undo for large PivotTable refresh operations to reduce refresh time”.

**Formatting Pivot Tables**

When you select a cell in a pivot table, the ribbon sprouts two new tabs under the PivotTable Tools heading: Analyze and Design. These tabs are similar to the ones that appear when you select a chart, table, or picture.

The Analyze tab accesses advanced features like custom calculations, filtering, and pivot charts. The Design tab changes the appearance of the active pivot table.

![PivotTable tab options](image)

The Design tab has three groups:

**PivotTables Styles**

Click a style to change the colors and shading of the pivot table. The colors come from the workbook theme that you’re using. To use different colors, choose Page Layout tab > Themes group > Themes.

**PivotTables Style Options**

If you don’t want shading to alternate from one row or column to the next, clear the Banded Rows or Banded Columns checkboxes. If you don’t want to apply the style
formatting to headers, clear the Row Headers or Column Headers checkboxes.

**Layout**

Choose a preset option that controls spacing and subtotals.

**Grand Totals.** Show or hide totals at the end of each row or column.

**Subtotals.** Show or hide subtotals at the end of each level. This setting applies only if fields are nested; that is, the Rows or Columns box contains more than one field. Otherwise, the levels’ “subtotals” are actually grand totals.

**Report Layout.** By default, pivot tables are shown in compact form: all row labels are merged into a single column, and each column just wide enough to fit that column’s widest entry. In outline form, each row label gets its own column, and each column is as wide as the widest column in the whole pivot table (which occupies much more space). Tabular form is like outline form but shows subtotals (extra rows) at the bottom of each level or group. You can also repeat labels to show values of nested fields in all row and column labels.

**Blank Rows.** Show or hide blank lines between levels or groups. This option applies only if the Rows box contains more than one field.

---

**Tip:** If you’re going to copy or export a pivot table from Excel to another program (such as a database or accounting program), use outline form and repeating labels.

---

**Showing a Value’s Source Data**

If you spot a trend, unexpected relationship, or an outlier (suspicious observation) in a pivot table, you can “drill down” to see exactly how the value was calculated. To do so, double-click any value cell in a pivot table. Excel creates a new worksheet containing copies of only the records that were used to calculate that cell’s value. This method is superior to the tedious alternative: switching to the worksheet that contains the original source data and then searching for the corresponding records.

The following pivot table shows how product categories (rows) perform in each country (columns). Double-click cell B5...
...and Excel adds a worksheet containing copies of the seven records (in a formatted table) whose Quantity values were summed to produce Argentine beverage sales.

After you finish examining the data, you can delete the worksheet that contains the copied records (right-click the worksheet tab at the bottom of the window and then choose Delete). The original source data aren’t touched when you delete the copy.

If you spot an error in the copied records, you must flip to the original source data to fix it. Obvious, yes, but it’s easy to absentmindedly change the copied records and then wonder why the refreshed pivot table doesn’t change.

**Changing a Pivot Table’s Source Data**

If you add rows to the bottom of a range of source data, you can redefine the pivot table’s source data to include those rows. Select any cell in the pivot table and then choose PivotTable Tools > Analyze tab > Data group > Change Data Source. The same fix applies if you add columns to the right edge of the source data.

**Tip:** If the source data are in an Excel table (Insert tab > Tables group > Table), then
you don’t have to change the range—newly added rows are displayed automatically when you refresh the pivot table.
2. Nesting Fields

You saw examples of one- and two-dimensional pivot tables in the preceding chapter, but Excel doesn’t limit the number of fields in a pivot table.

Adding Nested Fields

Each time that you add a new field, Excel subdivides, or nests, the current fields.

To add additional (nested) fields to a pivot table:

1. Select any cell in the pivot table.

   Excel shows the PivotTable Fields pane.

2. In the PivotTable Fields pane, drag fields from the “Choose fields to add to report” list to the Rows or Columns boxes underneath.

   The order of fields within a box determines their nesting order in the pivot table.

Consider a pivot table with the settings:

**Rows:** Product, Ship Country  
**Columns:** (empty)  
**Values:** Quantity (summarized by Sum)  
**Filters:** (empty)

Each row in this pivot table shows the total units of a specific product shipped to a specific country.
Excessive nesting can make a pivot table uninformative or unwieldy. If the number of rows in a pivot table is close to the number of rows in the underlying source data, then that pivot table isn’t truly a summary. Another sign of an overnested pivot table is an excessive number of empty cells (wasted space). Consider a pivot table with the settings:

**Rows:** Category, Order Date
**Columns:** Ship Country
**Values:** Quantity (summarized by Sum)
**Filters:** (empty)

The rows in this pivot table are grouped by category and subdivided by order date. At
1605 rows (not counting subtotals or blank values), this pivot table isn’t much smaller than the source data (2155 rows). The problem is that few orders fall on the same date. And when they do, they’re usually for different product categories. Consequently, many rows show results for only a single order, rather than true totals. This pivot table is sparse (contains many empty cells) because each row is further broken up into columns by country.

Nesting works best for closely related fields, such as Category and Product (each product falls in one category):
Make sure that you place the fields in the correct order in the Rows or Columns box; otherwise, you’ll get silly results. Consider a pivot table with the settings:

**Rows**: Product, Category  
**Columns**: (empty)  
**Values**: Quantity (summarized by Sum)  
**Filters**: (empty)

This pivot table groups the records by product and then subdivides the products by category, resulting in an unhelpful pivot table where each group contains a single subgroup (because each product falls in only one category). To fix this pivot table, swap the rows (that is, drag Product below Category in the Rows box).

**To reorder fields in a pivot table:**

1. Select any cell in the pivot table.
   
   Excel shows the PivotTable Fields pane.

2. In the PivotTable Fields pane, drag fields up or down within a box, or click a field in a box and then choose Move Up or Move Down (or Move to Beginning or Move to End) from the pop-up menu.

**Showing and Hiding Levels**
You can show (expand) or hide (collapse) individual levels in nested rows or columns, concealing the parts of a pivot table that you don’t want to see. In a pivot table that nests Product within Category, for example, you can show only the products in a specific category and hide the rest.

To show or hide specific levels:

- Do any of the following:
  - Click the plus (+) or minus (–) icon next to the level name in the pivot table (click again to toggle visibility).
  - Double-click the cell containing the level name (double-click again to toggle visibility).
  - Right-click the cell containing the level name and then choose Expand or Collapse from the Expand/Collapse submenu.

To show or hide all levels:

- Do any of the following:
  - In the target field, right-click any cell containing a level name and then choose Expand Entire Field or Collapse Entire Field from the Expand/Collapse submenu.
In the target field, select any cell containing a level name and then choose PivotTable Tools > Analyze tab > Active Field group > Expand Field or Collapse Field.

If you try to expand an innermost nested level, Excel opens the Show Detail dialog box listing all the fields *not* currently showing. If you select a field and then click OK, Excel adds another nested field to the pivot table.
3. Grouping Items

Pivot tables let you combine items into **groups**, which you can use to subset related values that can’t be easily combined by sorting, filtering, or other means. Numbers, dates, times, and user-selected items can be grouped.

**Grouping by Selected Items**

To create a custom group, select the items in the pivot table that you want to group, either by clicking or dragging, and then choose PivotTable Tools > Analyze tab > Group group > Group Selection (or right-click a selected cell and then choose Group from the shortcut menu).

**Tip:** To select adjacent cells, click the first cell and then Shift-click the last cell. To select nonadjacent cells, Ctrl-click each cell.

Consider a pivot table with the settings:

**Rows:** Ship Country  
**Columns:** (empty)  
**Values:** Quantity (summarized by Sum)  
**Filters:** (empty)

In the pivot table, Ctrl-click Canada, Mexico, and USA; right-click any selected item; and then choose Group.
Replace the default group name (Group1) with a meaningful name (North America). Excel also creates a new virtual field named Ship Country2 in the Rows box, which you can pivot on (drag Ship Country2 to the Columns box, for example). To remove the grouping, right-click the group name and then choose Ungroup.
### Nested Groups

You can create any number of groups and even create nested groups (groups of groups). When you create nested groups, it’s usually easiest to define the broadest (outermost) group first and then progress to the innermost groups.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Row Labels</strong></td>
<td><strong>Sum of Quantity</strong></td>
<td></td>
</tr>
<tr>
<td>Argentina</td>
<td></td>
<td>339</td>
</tr>
<tr>
<td>Austria</td>
<td></td>
<td>5167</td>
</tr>
<tr>
<td>Belgium</td>
<td></td>
<td>1392</td>
</tr>
<tr>
<td>Brazil</td>
<td></td>
<td>4247</td>
</tr>
<tr>
<td><strong>North America</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Canada</td>
<td></td>
<td>1984</td>
</tr>
<tr>
<td>Mexico</td>
<td></td>
<td>1025</td>
</tr>
<tr>
<td>USA</td>
<td></td>
<td>9330</td>
</tr>
<tr>
<td>Denmark</td>
<td></td>
<td>1170</td>
</tr>
<tr>
<td>Finland</td>
<td></td>
<td>885</td>
</tr>
<tr>
<td>France</td>
<td></td>
<td>3254</td>
</tr>
<tr>
<td>Germany</td>
<td></td>
<td>9213</td>
</tr>
<tr>
<td>Ireland</td>
<td></td>
<td>1684</td>
</tr>
<tr>
<td>Italy</td>
<td></td>
<td>822</td>
</tr>
<tr>
<td>Norway</td>
<td></td>
<td>161</td>
</tr>
<tr>
<td>Poland</td>
<td></td>
<td>205</td>
</tr>
<tr>
<td>Portugal</td>
<td></td>
<td>533</td>
</tr>
<tr>
<td>Spain</td>
<td></td>
<td>718</td>
</tr>
<tr>
<td>Sweden</td>
<td></td>
<td>2235</td>
</tr>
<tr>
<td>Switzerland</td>
<td></td>
<td>1275</td>
</tr>
<tr>
<td>UK</td>
<td></td>
<td>2742</td>
</tr>
<tr>
<td>Venezuela</td>
<td></td>
<td>2936</td>
</tr>
<tr>
<td><strong>Grand Total</strong></td>
<td></td>
<td>51317</td>
</tr>
</tbody>
</table>
Grouping by Time Periods

When a field contains dates or times, you can create groups that summarize data by time periods (hours, months, years, and so on). You can use the Order Date field, for example, to summarize sales by month. Consider a pivot table with the settings:

**Rows:** Order Date  
**Columns:** (empty)  
**Values:** Quantity (summarized by Sum)  
**Filters:** (empty)
In the pivot table, right-click any cell in the Order Date (Rows) column and then select Group from the shortcut menu. The Grouping dialog box opens. In the By list, select Months and Years. Verify that the starting and ending dates are correct and then click OK.

The Order Date items in the pivot table are grouped by years and by months. Excel also creates a new virtual field named Years in the Rows box, which you can pivot on (drag Years to the Columns box, for example). To remove the grouping, right-click any cell in the Order Date (Rows) column and then choose Ungroup.
**Tip:** If you select only Months (and not Years) in the By list, then months in different years are combined. The Aug item, for example, would show the combined quantities for 1994 and 1995 (the data stop in June, 1996).

### Grouping by Weeks

You can also group by week (or any fixed span of days). In the Grouping dialog box, select only Days (nothing else) in the By list and then type 7 in the “Number of days” box. Clear the “Starting at” checkbox and then adjust the start date to fall on the first day (typically, Sunday or Monday) of the first week of interest. If you like, adjust the end date too. Click OK.
Each row in the resulting pivot table shows the start and end dates of each week.
Grouping by Numbers

You can group by numbers to create a frequency distribution, where each entry in the pivot table contains the frequency (count) of the occurrences of values within a particular group or interval. Consider a pivot table with the settings:

**Rows:** Quantity  
**Columns:** (empty)  
**Values:** Quantity (summarized by Sum)  
**Filters:** (empty)

The pivot table shows the quantity of units sold and the corresponding number of orders. The goal is to determine how many quantities are in each 10-point range (1–10, 11–20,

![Pivot Table Example](image-url)
and so on).

In the pivot table, right-click any cell in the Quantity (Rows) column and then select Group from the shortcut menu.

The Grouping dialog box opens. In the By box, type the size of the interval for each group (here, 10). Verify that the starting and ending points are correct and then click OK.

The Quantity items in the pivot table are grouped in uniform intervals (bins). The groups start at 1 and end at 130, in increments of 10. A column chart of a frequency distribution is a histogram. To remove the grouping, right-click any cell in the Quantity (Rows) column and then choose Ungroup.
Tip: By default, pivot tables don’t display items with a count of zero. To make sure that your frequency distribution has no gaps between intervals, select any cell in the interval column and then choose PivotTable Tools > Analyze tab > Active Field group > Field Settings > Layout & Print tab > select “Show items with no data”.
4. Calculations and Custom Formulas

When you add a field to the Values box in the PivotTable Fields pane, Excel (in most cases) sums all the values in that field, but you can also calculate common statistics, do multiple calculations in the same pivot table, and create custom formulas.

Calculating Common Statistics

Excel’s preset calculations include common statistics: sum, count, average, maximum, percentage, rank, and so on.

To choose a preset calculation:

1. Select any cell in the pivot table.

   Excel shows the PivotTable Fields pane.

2. In the PivotTable Fields pane, click the target field (“Sum of Quantity”, for example) in the Values box and then choose Value Field Settings from the pop-up menu.

   The Value Field Settings dialog box opens.

3. In the “Summarize Values By” tab, choose a calculation in the list (Sum, Count, Average,...).
Alternatively, click the “Show Values As” tab to choose a more-complex calculation (percentage, difference, running total, rank, or index).

You can also change the default field name by typing a new name in the Custom Name box.

4. To format the field’s values, click Number Format, choose or define a new format, and then click OK.

You can change the number of decimal places, add a currency symbol, and so on.
5. Click OK to close the Value Field Settings dialog box.

Excel refreshes the pivot table with the new calculations.

**Showing Zeros in Empty Cells**

If the value of a pivot-table cell is zero, Excel shows it as an empty cell (inconsistent with non-pivot-table cells, which show zeros as zeros by default). To show zeros in a pivot table, right-click any cell in the pivot table and then choose PivotTable Options (or choose PivotTable Tools > Analyze tab > PivotTable group > Options). On the Layout & Format tab, clear the “For empty cells show” checkbox.

**Calculating Multiple Statistics**

When you add multiple fields to the Values box, each field is calculated and shown in a separate column in the pivot table. To sum the Quantity and average the Unit Price, for example, drag both fields into the Values box and then follow the steps above to configure each field separately.

Similarly, you can do multiple calculations on the *same* field. To sum and average Quantity, for example, drag Quantity into the Values box twice and then configure the two Quantity fields separately.

---

**Adding Custom Calculations**
In addition to choosing a preset calculation, you can define a custom calculated field in a pivot table.

To add a calculated field:

1. Select any cell in the pivot table.
2. Choose PivotTable Tools > Analyze tab > Calculations group > Fields, Items, & Sets > Calculated Field.

The Insert Calculated Field dialog box opens.

3. In the Name text box, type or paste a name for the new field.
4. In the Formula text box, enter the formula for this field.

The formula can use Excel’s built-in operators and functions, or change or combine one or more of the fields in the Fields list. To insert a field name in the formula quickly, double-click the name in the list. If you manually type a field name that contains spaces or special characters, enclose the name in single quotes ('Unit Price', for example).

5. Click OK.

In the PivotTable Fields pane, Excel adds the calculated field to the fields list and the Values box, so that it appears in the pivot table. Excel sums the formula for
Removing a custom field from the Values box removes it from the pivot table, but it remains in the fields list for later use. To permanently delete a custom field, select it from the Name drop-down list in the Insert Calculated Field dialog box (shown above) and then click Delete.

Tip: To list all calculated fields in a new worksheet, choose PivotTable Tools > Analyze tab > Calculations group > Fields, Items, & Sets > List Formulas.

Troubleshooting Calculated Fields

Calculated fields have the following restrictions:

- A calculated-field formula can’t refer to pivot-table grand totals or subtotals, nor can it refer to worksheet cells by address or by name.

- You can summarize a calculated field by only Sum.

- Because calculated-field formulas are always applied against the sum of the underlying data, Excel calculates data fields, subtotals, and grand totals before evaluating the calculated field.
In nontrivial formulas, the last restriction can cause unexpected results because the sum of products (generally) isn’t equal to the product of sums. In the example above, the calculated field returns a 10 percent per-item price discount when a customer orders 20 or more units of a particular item, and no (zero) discount otherwise. In the resulting pivot table, the individual Quantity calculations are correct but the subtotals for each Order ID aren’t what you’d expect (because Excel sums all an order’s quantities before determining whether discounts apply). Another common trap: if you create a calculated field named Revenue with the formula:

=’Unit Price’ * Quantity

then Excel sums the prices, sums the quantities, and then multiplies the two sums—which is not what you want.

Sadly, there’s no way to fix this problem, but there are a few (somewhat unsatisfying) workarounds for when you want sum-of-products and Excel is giving you product-of-sums:

- Add a column (field) to the underlying source data. In the sample workbook, for example, you can add a revenue formula to column J in the Source Data worksheet: type Revenue in cell J1, type:

  =D2*E2

  in cell J2 (Unit Price × Quantity), and then fill down (Ctrl+D) the J2 formula to the end of the data (cell J2156).

- Copy (Ctrl+C) and paste values (Ctrl+Alt+V) from the pivot table to work with independently elsewhere in the workbook.

- Write formulas outside the pivot table. You might want to turn off the GETPIVOTDATA function when you write formulas that refer to a pivot table (PivotTable Tools > Analyze tab > PivotTable group > Options arrow > Generate GetPivotData toggle).

- Turn off grand totals and subtotals in the pivot table (PivotTable Tools > Design tab > Layout group) and then calculate your own totals outside the pivot table.
5. Filtering Data

If a pivot table displays too much detail, you can filter (restrict) it to show only part of the source data. Excel offers several filters: report filters, slicers, and group filters.

Tip: If a pivot table’s data source is a table (Insert tab > Tables group > Table), then any filters that you apply directly to the table have no effect on linked pivot tables. To filter data from a pivot table, you must use one of the methods described in this chapter.

Report Filters

Report filters let you filter out data so that a pivot table uses only rows of interest in the source data. Start with a pivot table with the settings:

Rows: Category
Columns: Ship City
Values: Quantity (summarized by Sum)
Filters: (empty)

Now, to create a summary for only specific countries, drag the field Ship Country to the Filters box. The report filter field appears just above the pivot table. (If you use more than one report filter, each appears in a separate row.) To set the filter, click the drop-down arrow in the field box and then choose the countries that you want to display. To find an item, scroll the list or type the first few characters of its name in the search box. To filter for several items at the same time, turn on the Select Multiple Items checkbox and then select the desired items. When you’re done, click OK. When a filter is applied, the field box button changes to and a filter (funnel) icon appears in the field list in the PivotTable Fields pane.

Tip: To control how report filter fields are arranged in rows and columns, select any cell in the pivot table and then choose PivotTable Tools > Analyze tab > PivotTable group > Options > Layout & Format tab.
Excel uses checked items to create the pivot table, and ignores unchecked items. To quickly remove a report filter, choose the first item in the report filter list: “(All)”.  

Tip: Any fields that you use for report filtering can’t also be used for grouping. If you
filter by Ship Country, for example, you can’t also group by Ship Country. This restriction doesn’t apply to slicers and group filters.

**Slicers**

Slicers offer about the same features as report filters, but in “dashboard” format. Each slicer has its own floating window that you can format or drag around the main Excel window.

By contrast with report filters, slicers offer fast one-click filtering, and can filter and group on the same field. However, slicers tend to clutter your display with floating windows and don’t work well with fields that have many distinct values (which cause long scrolling distances). Also, slicers, like report filters, are less powerful than group filters.

**To create a slicer:**
1. Select any cell in the pivot table.

2. Choose PivotTable Tools > Analyze tab > Filter group > Insert Slicer.

   The Insert Slicers dialog box opens, listing all the fields in the pivot table (except custom fields).

```
Order ID
Product
Category
Unit Price
Quantity
Customer
Ship City
Ship Country
Order Date
```

3. Select the checkbox of each field that you want to use for filtering.

   Fields that have a small number of unique values make the best slicers because they fit well in a floating slicer window. Good choices: Category and Ship Country. Middling choices: Product and Customer. Poor choices: Unit Price and Order Date.

4. Click OK.

   Excel adds a separate floating window for each slicer.

5. Move or resize the floating slicer windows as desired.

   » To move a slicer, point to a border (the pointer turns into a four-way arrow) and then drag.

   » To resize a slicer, point to a corner or the middle of an edge (the pointer turns into a two-way arrow) and then drag.
6. Use the slicer window to apply filtering. The slicer window lists all the unique values in a field, each value appearing as a separate button. The buttons of *visible* values are shaded. No filtering is in effect in a newly created slicer window, so every button is shaded.

» To filter on a single value, click its button.

» To filter on multiple values, click the \( \equiv \) toggle button at the top of the slicer window (or press Alt+S) and then click the desired filter buttons. Alternatively, hold down the Ctrl key while you click each button. (To select a range of contiguous values, click the first button and then Shift-click the last button.)

» To clear filtering (show everything for the field), click the \( \times \) button at the top of the slicer window (or press Alt+C).

7. (Optional) Format the slicer.

» To change the button colors, choose Slicer Tools > Options tab > Slicer Styles gallery.

» To expand or compact the slicer window, choose Slicer Tools > Options tab > Buttons group, and then change the Columns, Height, and Width values. The following figure shows a three-column slicer window with custom button colors.
» To change the window title, choose Slicer Tools > Options tab > Slicer group > Slicer Caption box. To hide the window title, choose Slicer Tools > Options tab > Slicer group > Slicer Settings > clear “Display header”.

» To sort a slicer’s values, right click the slicer window and then choose a Sort command from the shortcut menu.

» To remove a slicer, click it and then press Delete (or right-click it and then choose the Remove command from the shortcut menu).

**Timelines**

Timelines offer a visual way to view and change a contiguous range of dates and filter pivot tables and pivot charts. Timelines work like slicers. To create a timeline, select any cell in the pivot table and then choose PivotTable Tools > Analyze tab > Filter group > Insert Timeline. Drag or click the timeline controls to select time periods. To format the timeline, select (click) it and then choose Timeline Tools > Options tab.

**Custom Slicer Styles**

You can create custom slicer styles to reuse with as many slicers as you want.

To create a custom slicer style:
1. Choose Slicer Tools > Options tab > Slicer Styles group. Click the drop-down arrow and then choose New Slicer Style.

The New Slicer Style dialog box opens.

2. In the Name box, type a name for the new slicer style.

3. In the Slicer Element list, select an element.

   Each element defines how a specific part of the slicer looks in a specific state. “Whole Slicer” formats the entire slicer and “Header” formats only the slicer’s window title. The specialized elements below “Header” format how an item looks when it’s selected, when it’s hovered over by the pointer, and when there’s no corresponding data for that value in the pivot table.

4. Click Format to format the selected element.

   The Format Slicer Element dialog box opens. Change the font, border, and fill as desired and then click OK.

5. To format other elements in the slicer, repeat steps 3 and 4.

6. Click OK to create the style.

   The custom style appears in the Slicer Styles gallery. You can apply it to any
slicer, or right-click it to modify, delete, or duplicate it.

**Group Filters**

Group filters—more powerful than report filters and slicers—let you filter fields that you’re using to group a pivot table to:

- Show or hide specific items (like report filters, except that you can’t create report filters for grouping fields).
- Create complex conditions that subset data. You can show or hide dates that fall in a specific time period, for example, or names that begin or end with a certain letter.
- Filter on multiple fields and configure them independently (Excel additively applies every filter at the same time).

The examples in this section use a pivot table with the settings:

**Rows:** Category, Product  
**Columns:** Ship Country  
**Values:** Quantity (summarized by Sum)  
**Filters:** (empty)

To create a group filter:
1. Click the drop-down arrow ▼ to the right of a Rows or Columns cell.

The filter list opens.

2. If you’re grouping on multiple fields, choose a field from the “Select field” drop-down list at top.

3. Set the desired options in the filter list and then click OK.
» To show or hide specific items, select or clear their checkboxes. To find an item, scroll the list or type the first few characters of its name in the search box.

» To show or hide items that contain specific text, begin or end with a certain letter, and so on, choose an option from the Label Filters submenu. To show only items that begin with “U”, for example, choose Label Filters > Begins With and then type U in the dialog box that opens.

![Label Filter (Ship Country)](image)

» To show or hide calculated values based on numerical criteria (less than, greater than, Top 10, and so on), choose an option from the Value Filters submenu. To show only items less than 500, for example, choose Value Filters > Less Than and then type 500 in the dialog box that opens.

![Value Filter (Product)](image)

» To sort items in ascending, descending, or custom order, choose a Sort command.

» To remove a filter (show everything for the field), choose the Clear Filter command. If you have multiple filters, you must remove each one separately. To remove them all at once (and show all data), choose PivotTable Tools > Analyze tab > Actions group > Clear > Clear Filters.

**Tip:** When a filter is applied, the button to the right of the Rows or Columns cell changes to and a filter (funnel) icon appears in the field list in the PivotTable Fields pane.

4. To filter by other grouping fields, repeat the preceding steps for each row label or column label.

**Filtering Nested Fields**
Label filters and value filters can get tricky when you work with nested fields. The effect of the Value Filters > Less Than > 500 command, for example, differs depending on whether you apply it to the Product or Category field (recall that Product is nested within Category in this example). Applied to Product, the pivot table shows products that sold fewer than 500 units (as you’d expect). Applied to Category, only categories with sales fewer than 500 units across all their products appear. Because every category has sales greater than 500 units in the current example, the filter hides every category and shows an empty pivot table (which is correct logically but might not be what you’d expect).

Note that if you apply a filter to a Rows field (Category or Products, in this example), your Columns fields (Ship Country) have no effect. Likewise, row filters don’t affect column filters.
6. Charting Pivot Tables

You can create charts based on the data in a pivot table. Pivot charts work the same as standard charts, but you may want to first filter a pivot table or remove excessive nesting to avoid creating charts with too many data series, which are hard to interpret and slow to refresh. Simple chart types like column and line charts work best (avoid 3-D effects, color gradients, gridlines, and other chartjunk).

**Tip:** Pivot charts, like pivot tables, are dynamic. As you drag fields in the PivotTable Fields pane from one area to another, Excel automatically refreshes the pivot table and pivot chart.

Creating Pivot Charts

You insert a pivot chart on a worksheet in the same way that you insert a standard chart.

**To create a pivot chart:**

1. Select any cell in the pivot table.

2. Choose PivotTable Tools > Analyze tab > Tools group > PivotChart.

   The Insert Chart dialog box opens.
3. Select the type of chart that you want and then click OK.

The pivot chart appears on the worksheet.

The following 100% Stacked Column chart shows Quantity by Category and Ship Country. Each color-coded bar is subdivided by country (denoted by the legend). The pivot table is filtered to show only a few categories and countries.

**Differences from Standard Charts**

Most of what you can do with standard charts, you can also do with pivot charts, except for the following differences.
Some chart types are prohibited
Pivot charts can’t be XY (scatter), bubble, stock, and some other types of charts.

Chart data range is defined differently
A standard chart is linked directly to worksheet cells, whereas a pivot chart is linked to a specific pivot table. You can’t use the Select Data Source dialog box (PivotChart Tools > Design tab > Data Group > Select Data) to change a pivot chart’s data range.

Some formatting isn’t preserved on refresh
Trendlines, data labels, error bars, and other changes to data sets are lost when you refresh the linked pivot table. Standard charts, in contrast, don’t lose their formatting when their source data recalculates.

Customizing Pivot Charts

You have several ways to manipulate and customize a pivot chart.

Format it
When you select (click) a pivot chart, the ribbon sprouts new tabs under the PivotChart Tools heading. These tabs, similar to the Chart Tools tabs for standard charts, change the formatting and layout of the chart, and configure chart elements such as titles, axes, and gridlines.

Move it
Excel places each pivot chart in a floating box. To move a chart, drag it (click an empty area of the chart to drag, or you may accidently drag or select only part of the chart). To move a chart to a new or different worksheet, click the chart and then choose PivotChart Tools > Analyze tab > Actions group > Move Chart. Alternatively, click the chart, press Ctrl+X (Home tab > Cut), switch to the target worksheet, and then press Ctrl+V (Home tab > Paste).

Apply group filters
You can apply group filters directly on a pivot chart. Click one of the field buttons on the chart to show a drop-down list of filtering options. It makes no difference whether you set the filtering options on the chart or on the pivot table itself. If these buttons clutter your chart, you can hide them: choose PivotChart Tools > Analyze tab > Show/Hide group > Field Buttons.

Tip: When you click a pivot chart, the section names in the PivotTable Fields pane change to reflect which parts of the pivot table are used to create the chart. The Rows box becomes Axis (Categories) and the Columns box becomes Legend (Series).
7. Tricks with Pivot Tables

Excel’s arsenal of pivot-table features offers a few nonobvious ways to solve common problems.

Creating a Frequency Tabulation

You can use a pivot table to quickly create a frequency tabulation for a single column of data. In the sample workbook, for example, switch to the Source Data worksheet, select the Ship Country column (click the H column heading), choose Insert tab > Tables group > PivotTable, and then create the pivot table. In the PivotTable Fields pane, drag the Ship Country field into the Rows box and then drag it again into the Values box. The resulting pivot table tallies the number of times that each country appears in the column. You can group, filter, and chart this tabulation as you would any pivot table. See also Grouping by Numbers.

Unlinking a Pivot Table from its Source Data

Excel doesn’t provide a direct way to “unlink” a pivot table from its source data, but you can create an unlinked copy of a pivot table in a few steps (handy if you want to send someone a pivot table summary report but not its underlying data).

To create an unlinked copy of a pivot table:
1. Select the entire pivot table.

   To select the entire pivot table, drag to select all the pivot table’s cells. Or click anywhere in the pivot table and then choose PivotTable Tools > Analyze tab > Actions group > Select arrow > Entire PivotTable.

2. Press Ctrl+C (Home tab > Clipboard group > Copy).

3. Choose Home tab > Clipboard group > Paste arrow > Values.

   Excel replaces the pivot table by its values, but without formatting.

4. In the Home tab > Clipboard group, click the tiny dialog box launcher icon in the bottom-right corner of the group.

   The Clipboard pane opens.

5. In the Clipboard pane (with the unlinked pivot table still selected), click the item that corresponds to the pivot table copy operation. That is, the most-recent action (unless you did something else in Office after the copy).

   Excel restores the original formatting in the unlinked pivot table. You can close the Clipboard pane.

Converting a Summary Table to a List

If you have a two-dimensional summary table (an ordinary range of cells—not a pivot table), you can reverse the usual pivot-table procedure by converting the summary table to a list. Data in list form can be easier to sort, filter, and update than data in summary form.

To convert a summary to a list, you must first add the PivotTable and PivotChart Wizard command to your Quick Access toolbar. Excel still supports this wizard, but it’s hidden by default.

To access the PivotTable and PivotChart wizard:

1. Right-click the Quick Access toolbar (at the top-left corner of the Excel window) and then choose Customize Quick Access Toolbar from the shortcut menu.
The Excel Options dialog box opens to the Quick Access Toolbar tab.

2. In the “Choose commands from” drop-down list, choose “Commands Not in the Ribbon”.

3. Scroll down the list (on the left) and then select PivotTable and PivotChart Wizard.

4. Click Add.

5. Click OK.

The PivotTable and PivotChart Wizard icon appears in the Quick Access toolbar.

The following example works for the specific summary table shown below, but you can easily modify the steps to work with your data.

To convert a summary table to a list:

1. Select any cell in the summary table.

2. In the Quick Access toolbar, click the PivotTable and PivotChart Wizard icon.

   The PivotTable and PivotChart Wizard dialog box opens.

3. Select “Multiple consolidation ranges” and then click Next.

4. Select “I will create the page fields” and then click Next.

5. Specify the range of the summary table in the Range box (here, A1:D5), click Add, and then click Next.
6. Specify a target location for the pivot table and then click Finish.

Excel creates a pivot table from the summary table and shows the PivotTable Fields pane.

7. In the PivotTable Fields pane, clear the checkboxes for the fields named Row and Column.

The pivot table shows a single field (Sum of Value), containing the sum of all the values in the table.

8. Double-click the cell that contains the total.
Excel creates a new worksheet that shows the original summary data in list form. Every value in the original summary table is converted to a row, which also contains the value’s corresponding row and column labels. You can change the default column headings (Row, Column, and Value) to meaningful names.

### Controlling References to Pivot Table Cells

If you create a formula that refers to a cell within a pivot table, Excel automatically converts the cell reference to a `GETPIVOTDATA` function with arguments. For example:

```
```

`GETPIVOTDATA` ensures that formulas still return the correct results even if you rearrange the pivot table. To avoid `GETPIVOTDATA` autoconversion, don’t point to (click) the cell when you create the formula; instead, type the cell reference manually. To turn on or off `GETPIVOTDATA` autoconversion, choose PivotTable Tools > Analyze tab > PivotTable group > Options arrow > Generate GetPivotData toggle. Alternatively, choose File tab > Options > Formulas (on the left) > “Use GetPivotData functions for PivotTable references” checkbox.

### Replicating a Pivot Table for Report Filter Items

You can set up a pivot table and then replicate it for every distinct value of a report filter. This feature isn’t popular because it generates multiple pivot tables when a single
nested and filtered pivot table should suffice for most purposes. It may be useful for generating separate tables or charts to paste in different slides in a presentation. Consider a pivot table with the settings:

**Rows:** Category  
**Columns:** (empty)  
**Values:** Quantity (summarized by Sum)  
**Filters:** Ship Country

Choose PivotTable Tools > Analyze tab > PivotTable group > Options arrow > Show Report Filter Pages command. In the Show Report Filter Pages dialog box that opens, select Ship Country and then click OK. Excel replicates the pivot table for every country, creating a worksheet for each new pivot table (inspect the worksheet tabs at the bottom of the Excel window).

**Sorting a Pivot Table Manually**

You can sort the rows or columns of a pivot table automatically by clicking the drop-down arrow to the right of a Rows or Columns cell, or sort them manually by dragging.
To sort a pivot table manually:

1. In the pivot table, right-click any row or column label of the field that you want to sort and then choose Sort > More Sort Options > Manual > OK.

2. Select the label cell of the row or column that you want to move. If you want to move a group of adjacent rows or columns, drag to select multiple label cells.

3. Hover the pointer over the border of the selected label cell(s) until the pointer changes to a four-way arrow (called a move pointer). You may have to move the pointer slowly around the border until it changes to a move pointer.

4. Drag the selected row(s) or column(s) to another location within the pivot table.

   As you drag, a thin line appears to show where the selection will land when dropped.